- Added `cachix.nix` for configuring Cachix substituters - Added `cachix/nix-community.nix` for Nix Community Cachix settings - Updated `lib/host.nix` to include `pkgs.nixosModules.cachixConfig` in the list of NixOS modules
14 lines
419 B
Nix
14 lines
419 B
Nix
|
|
# WARN: this file will get overwritten by $ cachix use <name>
|
|
{ pkgs, lib, ... }:
|
|
|
|
let
|
|
folder = ./cachix;
|
|
toImport = name: value: folder + ("/" + name);
|
|
filterCaches = key: value: value == "regular" && lib.hasSuffix ".nix" key;
|
|
imports = lib.mapAttrsToList toImport (lib.filterAttrs filterCaches (builtins.readDir folder));
|
|
in {
|
|
inherit imports;
|
|
nix.settings.substituters = ["https://cache.nixos.org/"];
|
|
}
|