46 lines
1000 B
Nix
46 lines
1000 B
Nix
{ pkgs, ... }:
|
|
|
|
let
|
|
network = import ./network.nix;
|
|
domain = "jellyfin.giugl.io";
|
|
in {
|
|
disabledModules = [ "services/misc/jellyfin.nix" ];
|
|
imports = [ ./modules/jellyfin.nix ];
|
|
|
|
services = {
|
|
jellyfin = {
|
|
enable = true;
|
|
group = "media";
|
|
package = pkgs.unstable.jellyfin;
|
|
};
|
|
|
|
nginx.virtualHosts.${domain} = {
|
|
# forceSSL = true;
|
|
# enableACME = true;
|
|
locations."/" = {
|
|
proxyPass = "http://localhost:8096";
|
|
extraConfig = ''
|
|
allow 10.0.0.0/24;
|
|
allow 10.3.0.0/24;
|
|
deny all;
|
|
'';
|
|
};
|
|
};
|
|
};
|
|
|
|
networking.extraHosts = ''
|
|
${network.architect-lan} ${domain}
|
|
${network.architect-wg} ${domain}
|
|
'';
|
|
|
|
users.groups.media.members = [ "jellyfin" ];
|
|
users.groups.video.members = [ "jellyfin" ];
|
|
users.groups.render.members = [ "jellyfin" ];
|
|
|
|
fileSystems."/tmp/jellyfin" = {
|
|
device = "none";
|
|
fsType = "tmpfs";
|
|
options = [ "defaults" "size=20G" "uid=jellyfin" ];
|
|
};
|
|
}
|